#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d\d(?:([.,])\d(?:\d(?:\1\d\d?|)|)|)(?: \d\d(?:([.,])\d(?:\d(?:\2\d\d?|)|)|))*$"
Local $sString = "Нужно захватывать такие виды оквэдов (1 === \d{1}):" & @CRLF & _
"11" & @CRLF & _
"11.1" & @CRLF & _
"11,1" & @CRLF & _
"11.11" & @CRLF & _
"11,11" & @CRLF & _
"11.11.1" & @CRLF & _
"11,11,1" & @CRLF & _
"11.11.11" & @CRLF & _
"11,11,11" & @CRLF & _
"11 11.11 11.11.11" & @CRLF & _
"11 11,11 11,11,11" & @CRLF & _
"" & @CRLF & _
"Недопустимы:" & @CRLF & _
"11,11.11" & @CRLF & _
"11.11,11" & @CRLF & _
"11.1.11" & @CRLF & _
"11.1.1" & @CRLF & _
"11." & @CRLF & _
"11," & @CRLF & _
"11.1." & @CRLF & _
"11,1," & @CRLF & _
"11.11." & @CRLF & _
"11,11," & @CRLF & _
"11.11.1." & @CRLF & _
"11,11,1," & @CRLF & _
"11.11.11." & @CRLF & _
"11,11,11," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")