const regex = /^\d\d(?:([.,])\d(?:\d(?:\1\d\d?|)|)|)(?: \d\d(?:([.,])\d(?:\d(?:\2\d\d?|)|)|))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d\\d(?:([.,])\\d(?:\\d(?:\\1\\d\\d?|)|)|)(?: \\d\\d(?:([.,])\\d(?:\\d(?:\\2\\d\\d?|)|)|))*$', 'gm')
const str = `Нужно захватывать такие виды оквэдов (1 === \\d{1}):
11
11.1
11,1
11.11
11,11
11.11.1
11,11,1
11.11.11
11,11,11
11 11.11 11.11.11
11 11,11 11,11,11
Недопустимы:
11,11.11
11.11,11
11.1.11
11.1.1
11.
11,
11.1.
11,1,
11.11.
11,11,
11.11.1.
11,11,1,
11.11.11.
11,11,11,
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}