import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d\\d(?:([.,])\\d(?:\\d(?:\\1\\d\\d?|)|)|)(?: \\d\\d(?:([.,])\\d(?:\\d(?:\\2\\d\\d?|)|)|))*$";
final String string = "Нужно захватывать такие виды оквэдов (1 === \\d{1}):\n"
+ "11\n"
+ "11.1\n"
+ "11,1\n"
+ "11.11\n"
+ "11,11\n"
+ "11.11.1\n"
+ "11,11,1\n"
+ "11.11.11\n"
+ "11,11,11\n"
+ "11 11.11 11.11.11\n"
+ "11 11,11 11,11,11\n\n"
+ "Недопустимы:\n"
+ "11,11.11\n"
+ "11.11,11\n"
+ "11.1.11\n"
+ "11.1.1\n"
+ "11.\n"
+ "11,\n"
+ "11.1.\n"
+ "11,1,\n"
+ "11.11.\n"
+ "11,11,\n"
+ "11.11.1.\n"
+ "11,11,1,\n"
+ "11.11.11.\n"
+ "11,11,11,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}