#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:10|[0-9])[A-J](?:10|[1-9])$"
Local $sString = "0A1" & @CRLF & _
"10J10" & @CRLF & _
"6A10" & @CRLF & _
"1B0" & @CRLF & _
"11A5" & @CRLF & _
"1H11" & @CRLF & _
"3Q8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")