const regex = /^(?:10|[0-9])[A-J](?:10|[1-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:10|[0-9])[A-J](?:10|[1-9])$', 'gm')
const str = `0A1
10J10
6A10
1B0
11A5
1H11
3Q8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}