// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:10|[0-9])[A-J](?:10|[1-9])$").unwrap();
let string = "0A1
10J10
6A10
1B0
11A5
1H11
3Q8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}