package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:10|[0-9])[A-J](?:10|[1-9])$`)
var str = `0A1
10J10
6A10
1B0
11A5
1H11
3Q8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}