using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\d+(?:\.\d+)?,\d+(?:\.\d+)?\)";
string input = @"(1.01,3.21)(3.01,4.51)(2.1,5.6)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}