$re = '/\(\d+(?:\.\d+)?,\d+(?:\.\d+)?\)/';
$str = '(1.01,3.21)(3.01,4.51)(2.1,5.6)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);