package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\d+(?:\.\d+)?,\d+(?:\.\d+)?\)`)
var str = `(1.01,3.21)(3.01,4.51)(2.1,5.6)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}