// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(\d+(?:\.\d+)?,\d+(?:\.\d+)?\)").unwrap();
let string = "(1.01,3.21)(3.01,4.51)(2.1,5.6)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}