package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\W_].+$`)
var str = `abc
123
abc123
abc123!@#
abc!@#123
123!@#abc
!@#
!@#abc
!@#123
!@#abc123
_hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}