re = /^[^\W_].+$/m
str = 'abc
123
abc123
abc123!@#
abc!@#123
123!@#abc
!@#
!@#abc
!@#123
!@#abc123
_hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end