$re = '/^[^\W_].+$/m';
$str = 'abc
123
abc123
abc123!@#
abc!@#123
123!@#abc
!@#
!@#abc
!@#123
!@#abc123
_hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);