import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\W_].+$";
final String string = "abc\n"
+ "123\n"
+ "abc123\n"
+ "abc123!@#\n"
+ "abc!@#123\n"
+ "123!@#abc\n\n"
+ "!@#\n"
+ "!@#abc\n"
+ "!@#123\n"
+ "!@#abc123\n"
+ "_hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}