package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)array(\(((?:[^()]++|(?1))*)\))`)
var str = `drupal_add_js(array('my_common' => array('my_code_validate' => variable_get('my_code_validate', FALSE), 'inner_index2 => 'inner_value2'), 'another_item' => 'another_value'), 'setting');
'my_common' => array('my_code_validate' => variable_get('my_code_validate', FALSE), 'inner_index2 => 'inner_value2'), 'another_item' => 'another_value'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}