re = /array(\(((?:[^()]++|(?1))*)\))/m
str = 'drupal_add_js(array(\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\'), \'setting\');
\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end