$re = '/array(\(((?:[^()]++|(?1))*)\))/m';
$str = 'drupal_add_js(array(\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\'), \'setting\');
\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);