using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)_(.*)";
string input = @"chicken_panfry1_t360_ketchup
chicken_bake2_t450_out_bbq
chicken_boiled2_season_gravy";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}