$re = '/(.*)_(.*)/m';
$str = 'chicken_panfry1_t360_ketchup
chicken_bake2_t450_out_bbq
chicken_boiled2_season_gravy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);