// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)_(.*)").unwrap();
let string = "chicken_panfry1_t360_ketchup
chicken_bake2_t450_out_bbq
chicken_boiled2_season_gravy";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}