re = /(.*)_(.*)/m
str = 'chicken_panfry1_t360_ketchup
chicken_bake2_t450_out_bbq
chicken_boiled2_season_gravy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end