# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[a-zA-Z]),(?=\d)/ /gm;t' <<< "a,1.50,b,2.00,c,2.50"