$re = '/(?<=[a-zA-Z]),(?=\d)/m';
$str = 'a,1.50,b,2.00,c,2.50';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;