import re
regex = re.compile(r"(?<=[a-zA-Z]),(?=\d)", flags=re.MULTILINE)
test_str = "a,1.50,b,2.00,c,2.50"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)