use strict;
my $str = 'a,1.50,b,2.00,c,2.50';
my $regex = qr/(?<=[a-zA-Z]),(?=\d)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";