using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*@==(.*?)(?:\?.*)?$";
string input = @" https://example.com/helloworld/.@==imhere
https://example.com/helloworld/.@==imnothere?param1=value1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}