re = /^.*@==(.*?)(?:\?.*)?$/m
str = ' https://example.com/helloworld/.@==imhere
https://example.com/helloworld/.@==imnothere?param1=value1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end