$re = '/^.*@==(.*?)(?:\?.*)?$/m';
$str = ' https://example.com/helloworld/.@==imhere
https://example.com/helloworld/.@==imnothere?param1=value1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);