package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*@==(.*?)(?:\?.*)?$`)
var str = ` https://example.com/helloworld/.@==imhere
https://example.com/helloworld/.@==imnothere?param1=value1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}