#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:\G(?!\A).*\R\h*|^>>\s*)\K\S+"
Local $sString = ">>" & @CRLF & _
" " & @CRLF & _
" https://sharefile.com/Authentication/Login some stuff" & @CRLF & _
" https://fox1.functionfox.com/timefox/main.asp" & @CRLF & _
"" & @CRLF & _
"<<SECTION>>" & @CRLF & _
" " & @CRLF & _
" behance.net" & @CRLF & _
" http://www.twitter.com" & @CRLF & _
" http://theoldreader.com" & @CRLF & _
" http://www.reddit.com " & @CRLF & _
" https://mail.google.com" & @CRLF & _
" https://analytics.google.com/analytics/web/#home" & @CRLF & _
" http://www.youtube.com" & @CRLF & _
"" & @CRLF & _
"<<SECTION>>" & @CRLF & _
"" & @CRLF & _
" www.google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")