re = /(?:\G(?!\A).*\R\h*|^>>\s*)\K\S+/im
str = '>>
https://sharefile.com/Authentication/Login some stuff
https://fox1.functionfox.com/timefox/main.asp
<<SECTION>>
behance.net
http://www.twitter.com
http://theoldreader.com
http://www.reddit.com
https://mail.google.com
https://analytics.google.com/analytics/web/#home
http://www.youtube.com
<<SECTION>>
www.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end