import re
regex = re.compile(r"(?:\G(?!\A).*\R\h*|^>>\s*)\K\S+", flags=re.IGNORECASE | re.MULTILINE)
test_str = (">>\n"
" \n"
" https://sharefile.com/Authentication/Login some stuff\n"
" https://fox1.functionfox.com/timefox/main.asp\n\n"
"<<SECTION>>\n"
" \n"
" behance.net\n"
" http://www.twitter.com\n"
" http://theoldreader.com\n"
" http://www.reddit.com \n"
" https://mail.google.com\n"
" https://analytics.google.com/analytics/web/#home\n"
" http://www.youtube.com\n\n"
"<<SECTION>>\n\n"
" www.google.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")