import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A).*\\R\\h*|^>>\\s*)\\K\\S+";
final String string = ">>\n"
+ " \n"
+ " https://sharefile.com/Authentication/Login some stuff\n"
+ " https://fox1.functionfox.com/timefox/main.asp\n\n"
+ "<<SECTION>>\n"
+ " \n"
+ " behance.net\n"
+ " http://www.twitter.com\n"
+ " http://theoldreader.com\n"
+ " http://www.reddit.com \n"
+ " https://mail.google.com\n"
+ " https://analytics.google.com/analytics/web/#home\n"
+ " http://www.youtube.com\n\n"
+ "<<SECTION>>\n\n"
+ " www.google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}