package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_([^_]+)(_[^_]*){3}$`)
var str = `channel_product_country_medium_brand_offer_campaignname_ctatext_date_objective_0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}