// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_([^_]+)(_[^_]*){3}$").unwrap();
let string = "channel_product_country_medium_brand_offer_campaignname_ctatext_date_objective_0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}