re = /_([^_]+)(_[^_]*){3}$/m
str = 'channel_product_country_medium_brand_offer_campaignname_ctatext_date_objective_0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end