using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d+ (?:minute|hour)s? ?){1,2}";
string input = @"(30 minutes|1 hour|1 hour 30 minutes|2 hours|2 hours 30 minutes|3 hours|3 hours 30 minutes|4 hours)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}