const regex = new RegExp('(?:\\d+ (?:minute|hour)s? ?){1,2}', 'gm')
const str = `(30 minutes|1 hour|1 hour 30 minutes|2 hours|2 hours 30 minutes|3 hours|3 hours 30 minutes|4 hours)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}