re = /(?:\d+ (?:minute|hour)s? ?){1,2}/m
str = '(30 minutes|1 hour|1 hour 30 minutes|2 hours|2 hours 30 minutes|3 hours|3 hours 30 minutes|4 hours)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end