package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d+ (?:minute|hour)s? ?){1,2}`)
var str = `(30 minutes|1 hour|1 hour 30 minutes|2 hours|2 hours 30 minutes|3 hours|3 hours 30 minutes|4 hours)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}