#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)100(\.[0]{1,2})?|([0-9]|[1-9][0-9])(\.[0-9]{1,2})? %"
Local $sString = "Service Level Report for BESIX CONSTRUCT L.L.C For October 2022 to December 2022 Section 1 - SLA Status DPI Basic Availability Service details Uptime Comments" & @CRLF & _
"Description" & @CRLF & _
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 99 100.00 % Complied" & @CRLF & _
"construct LLC DPI Basic Jitter Service details Uptime Comments" & @CRLF & _
"Description" & @CRLF & _
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 79.44 % Violated" & @CRLF & _
"construct LLC DPI Basic Latency Service details Uptime Comments" & @CRLF & _
"Description" & @CRLF & _
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 98.94 % Complied" & @CRLF & _
"construct LLC DPI Basic Packet Loss Service details Uptime Comments" & @CRLF & _
"Description" & @CRLF & _
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 99.93 % Complied" & @CRLF & _
"construct LLC 24/02/2023 15:07:08 +0400"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")