using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"100(\.[0]{1,2})?|([0-9]|[1-9][0-9])(\.[0-9]{1,2})? %";
string input = @"Service Level Report for BESIX CONSTRUCT L.L.C For October 2022 to December 2022 Section 1 - SLA Status DPI Basic Availability Service details Uptime Comments
Description
Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 99 100.00 % Complied
construct LLC DPI Basic Jitter Service details Uptime Comments
Description
Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 79.44 % Violated
construct LLC DPI Basic Latency Service details Uptime Comments
Description
Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 98.94 % Complied
construct LLC DPI Basic Packet Loss Service details Uptime Comments
Description
Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 99.93 % Complied
construct LLC 24/02/2023 15:07:08 +0400";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}