# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"100(\.[0]{1,2})?|([0-9]|[1-9][0-9])(\.[0-9]{1,2})? %"
test_str = ("Service Level Report for BESIX CONSTRUCT L.L.C For October 2022 to December 2022 Section 1 - SLA Status DPI Basic Availability Service details Uptime Comments\n"
"Description\n"
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 99 100.00 % Complied\n"
"construct LLC DPI Basic Jitter Service details Uptime Comments\n"
"Description\n"
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 79.44 % Violated\n"
"construct LLC DPI Basic Latency Service details Uptime Comments\n"
"Description\n"
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 98.94 % Complied\n"
"construct LLC DPI Basic Packet Loss Service details Uptime Comments\n"
"Description\n"
"Service Type Media Option Committed Actual Status 900102711890_DPI - DPI - Main - Besix Basic IDA Fiber/- Basic 95 99.93 % Complied\n"
"construct LLC 24/02/2023 15:07:08 +0400")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.