using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[_a-zA-Z][-_a-zA-Z0-9:]*";
string input = @"data-test
data-test_test
href
1test
test2
test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}