package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[_a-zA-Z][-_a-zA-Z0-9:]*`)
var str = `data-test
data-test_test
href
1test
test2
test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}