re = /[_a-zA-Z][-_a-zA-Z0-9:]*/m
str = 'data-test
data-test_test
href
1test
test2
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end