$re = '/[_a-zA-Z][-_a-zA-Z0-9:]*/m';
$str = 'data-test
data-test_test
href
1test
test2
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);