#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(\d+[A-C]?)-(\d+[A-C]?)"
Local $sString = "137 9/F 135-138A KING STREET TOR" & @CRLF & _
"137 9/F 135-138 KING STREET TOR" & @CRLF & _
"137 9/F 135A-138A KING STREET TOR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")