use strict;
my $str = '137 9/F 135-138A KING STREET TOR
137 9/F 135-138 KING STREET TOR
137 9/F 135A-138A KING STREET TOR';
my $regex = qr/(\d+[A-C]?)-(\d+[A-C]?)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}